miércoles, 19 de agosto de 2009

Restablecido


Qué me gusta a mí reinstalar mi sistema. Aunque lo malo de esto es que esta vez ha sido por un disco duro que ya no daba más de sí, como ya os conté. Como contar mis hazañas informáticas me gusta tanto o más como vivirlas, preparaos para una entrada bien larga.

Empiezo la historia desde donde la dejé. El disco duro estaba agonizante, y hacía "click" cada pocas horas. El domingo por la noche no dormí nada, y tuve el PC encendido bastante tiempo en, sin que lo hiciera. Por la mañana, me tumbo en el sofá con lógicas consecuencias: me dormí. El ordenador encendido. Cuando me despierto, me encuentro con un bicho lentísimo en el que no se podía hacer nada, y cuando digo nada es nada. Pensando que iba a ser como otras veces, que se le quitaba el click, reinicié.

Pero esta vez no. La BIOS tardaba en arrancar. Me decía que el disco duro estaba deshabilitado, que no se podía bootear desde él, y el click del mismo era continuo. "DEP disco duro, fue bonito mientras duró", pensé.

Por razones de la vida que no voy a relatar aquí (mi hermano que es quien sabe abrir ordenadores no le salió de los huevos hacerlo el lunes), hasta el martes no pude tener el disco duro de 500GB como primario para empezar a instalar todo de nuevo. Y aquí es donde realmente empieza la odisea.

Cuando el PC estaba agonizante, me bajé un DVD de Debian Testing reciente y lo grabé. Pero lo grabé con click y con el PC lentísimo. Cuando empezaba a grabar siempre era igual, de modo que no pud hacer otra cosa. La grabación se completó con éxito, o al menos eso me dijo Brasero. Pero no fue así. No cargaba ni el instalador.

¿Por qué confié en un disco grabado en un ordenador moribundo? No sé, ¿por qué no me bajé una ISO desde el PC de mi hermano y lo grabé allí? Tampoco lo sé. El caso es que a la hora de instalar (y yo sólo quería instalar Debian) me encontré con un DVD de Debian Testing anterior a la salida de Lenny estable. Lo que quiere decir, muy antigua.

Pero era mi única opción. No quería instalar Ubuntu (del que poseo un disco del Ship-it de la última versión), así que como un machote me puse a instalar una distro con Gnome 2.22 y un kernel 2.6.24, cuando el último en testing es el 2.6.30. Y se instaló. Y reinicié. Y me encontré en un Gnome antiiguo.

Tras compilar el driver para mi tarjeta inalámbrica RT2500 (paquete que tenía en el pendrive sabiendo el panorama que me iba a encontrar), metí repositorios de Testing recientes, actualicé y... 1200 paquetes por bajar, 1 giga y pico. Pensé: no. Pensé: me bajo un CD con Xfce y lo instalo. Pensé: me gustan los retos. Pensé: me gustan los retos pero no soy imbécil, actualizar tantas cosas a la vez pueden joder el sistema al reiniciar, así que voy a bajarme una ISO con Xfce por si acaso. Y así hice. Empecé a bajar la ISO de Debian Testing CD1 con Xfce y a la vez, Synaptic descargaba paquetes como no lo había hecho nunca.

Varias cosas a tener en cuenta. La mayoría de los paquetes que iba a actualizar luego iban a ir fuera. ¿Por qué no instalé Xfce desde el DVD, hice purga de Gnome y todas sus librerías, para luego actualizar y quitarme bastantes megas de descarga? Se me ha ocurrido mientras escribo esto. Así que actualicé todo Gnome y todo el sistema base y lo que no es tan base. Mi sorpresa fue mayúscula cuando me encontré que synaptic, por algún motivo que no alcanzo a comprender, bajó muchos paquetes debugging (acabados en -dbg), que pesan mucho al descargarse y aún más instalados. Pero no quería detener la descarga así que los bajé.

Tras la macro-actualización e instalación de paquetes, reinicié, ya con el kernel 2.6.30. En este kernel no he tenido que compilar el driver para la tarjeta de red, viene con él y funciona como debe. Entonces instalé Xfce, y una vez allí, empecé a borrar librerías de Gnome, a Gnome en sí, y todos los paquetes debugging. Calculo que me deshice de más de 600 megas de los que se habían instalado.

Pero el caso es que ya tenía un Xfce y un kernel actualizado. Hora de empezar a configurar todo. Impresora, bluetooth, tableta, todo sin problemas. Y cuando me di cuenta había dejado algunos detalles muy importantes para el final.

El driver de Nvidia. Yo tenía un driver en el pendrive, actualizado, pensaba yo. Tras apagarse el router y ponerme los cojones de corbata pensando que había roto algo, instalé las cabeceras del núcleo para compilar, la compilación empiza y... error. "Buah, ya está, este kernel tan nuevo no tiene driver... Tranquilo, ve a la web de Nvidia y bájate un driver más nuevo, que este tiene ya siglos". Y tras realizar esta sencilla operación, descargar un ejecutable reciente, la compilación del driver se completó con éxito. Como si fuera un novato, no tener el último driver. Pero ya tenía mi gráfica bien.

De un error de novato a otro, pongo un archivo MP3, con drivers insalados, y no suena. Tras pensar, de nuevo, "ya he roto algo", me da por mirar a los altavoces para comporbar que estaban apagados. Tras el grandioso gesto para encenderlos, el archivo sonó con toda claridad y calidad.

Una vez configurado todo el hardware, empecé con las configuraciones de software. En el pendrive tenía muchos datos de configuración que guardé por pereza a ponerlo todo otra vez a mi gusto. O sea que cuando instalé Liferea, Gpodder, actualizar iceWeasel, Pidgin y otros programas que no recuerdo, me los encontré tal y como los solté.

Para acabar y como nota curiosa, decir que en mi anterior instalación, en Skype no se escuchaba bien mi voz al hablar con alguien. Pero ahora sí que se oye bien, tras tocar la configuración del programa y el mezclador. O sea que algo que he ganado: ya no tengo que hacer uso del Eee para hablar decentemente por Skype, que er mi recurso anterior.

Y de momento ya está, esperando que no pase nada raro al reiniciar, que todo esté bien, y que este disco duro aguante otro tiempo, a ser posible mayor, que entre ventilador, disco duro y tonterías, he tenido que tocar el ordenador una vez al año desde que lo tengo, y siempre en agosto. De entrada ahora tengo un disco duro de 500 gigas que pienso aprovechar.

2 comentarios:

Hijo del Opio dijo...

Te parecerá increíblemente extraña la coincidencia, pero yo he tenido un problema similar, resulta que de un momento a otro mi disco duro dejo de funcionar hace como tres días, así que resignado me fui a comprar otro nuevo (algo que de todas formas pensaba hacer, pero no tan pronto)

Llegue a casa con mi flamante disco nuevo y procedí a instalarlo, para luego claro instalarle Debian Testing... o eso pensaba porque cuando me puse a buscar el jodido cd con el Debian Testing de 64 bits, no lo encontré en ningún lado.

Maldije unas cuantas veces y resignado otra vez, me puse a bajar una iso de testing desde mi computador viejo, (actualmente de mi hermano)para luego con un live CD de Dream Linux quemarla.

Todo bien y sin problemas... aparentemente, porque al momento de instalarla la instalación se queda pegada al arrancar.

Pensé inocentemente que el problema era causado por quemar la iso desde un Live cd, así que resignándome por tercera vez, use el cd de Debian testing de 32bits que tenia, y lo instale temporalmente para poder grabar la iso otra vez. Una vez instalado el sistema. (solo lo básico para grabar el CD con el)

Grabado el CD otra vez, trate de instalar el sistema, pero volvió a ocurrir lo mismo, se quedaba pegado al arrancar... ya un poco cabreado, intente bajarme otra iso, pero las pinches isos que bajaba no terminaban de grabar bien y daban error, y las que no, se quedaban en el arranque ¬¬

El nivel de cabreo llego a un punto tal que hice pedazos el grabador, algo no muy inteligente, pero sumamente satisfactorio.

Como ya no contaba con el Grabador, decidí quedarme con el Debian de 32bits, pero cuando intente instalarme los drivers de Nvidia a la Debian, con Module Assistant y toda esa vaina, desgraciadamente descubrí para mi horror que me daba un error al instalarlos, y peor aun, descubrí también que mi nueva compu tiene algo bastante desagradable, y es que sin los drivers de video, el monitor empieza a emitir un pitido fuerte y molesto al cabo de unos cuantos minutos, lo que realmente me estaba enloqueciendo.

Imposibilitado para buscar una solución por internet por causa del insoportable ruido, decidí casi en contra de mi buen juicio, instalar la versión LTS de Xubuntu, para así poder compilar el driver manualmente, sin el problema de incompatibilidad con el compilador que da en Debian, y en eso estoy ahora, con un Xubuntu viejuno, pero con soporte, que tendré que tragarme hasta juntar el dinero para comprarme un nuevo grabador.

Por cierto, lo mas gracioso es que cuando finalmente iva a cerrar el tarro, me di cuanta de algo que no había notado antes al instalar el disco nuevo, y es que el cable sata del disco viejo, se había separado del conector, temiéndome lo peor, saque otro cable sata que tenia de mi viejo equipo, y lo probé con el disco duro, y efectivamente, el maldito infeliz estaba perfecto, osea que me gaste una pasta en un disco nuevo que finalmente no necesitaba... amo mi vida

getse dijo...

En serio yo de linux se lo justo y necesario, yo usaba un cd k ponias en le ordenador y para usarlo debias reiniciar para k se ejecutara, con eso me valia pork solo es para hacer practicas.
Bueno de lo que realmente se da cuenta uno es de las tonterias que comete cuando se pone nervioso aunk las haya hecho mil veces antes

Publicar un comentario

Si no tienes cuenta en ninguno de los servicios, usa Nombre/URL. A ser posible, evita la opción Anónimo.

 
Related Posts with Thumbnails